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Introduction

Welcome to the YoupiPaint User Guide.

To get help, click on the help topics on the left.

 

Getting started

YoupiPaint  is a drawing and image processing application that has been specially designed for the
production of digital art. YoupiPaint allows you to draw, paint and transform the drawing with many tools.

YoupiPaint includes:

· To draw, to paint with a variety of pencils, brushes, brushes

· To apply effects to the drawing

· Manage your color palettes

· To draw on layers, layers stacked one to another

Although the basic features offer great possibilities, if your needs are not covered by the YoupiPaint
standard, you can develop and customize your own brushes and effects through the integrated development
studio.

YoupiPaint has been developed in a constant concern for performance, including on large documents.

System requirements

Required configuration

Windows

· Windows 7, 8 or 10

· Works on 32-bit or 64-bit versions of Windows

· Graphics card compatible with OpenGL 2.0 or higher

· Resolution 1024 x 768 or higher

· 1 GB of disk space (to optimize operations, YoupiPaint uses a disk cache, the space used depends on
the options you choose). 2 GB recommended
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· 2 GB RAM or more, 4 GB recommended.

· Internet connection for accessing on line help and downloading

Graphic tablet

· All tablets compatible with the Wintab API

· YoupiPaint has been successfully tested on Wacom tablets

To check YoupiPaint compatibility with your system and tablet, download and try the free version before
purchasing.

Installation

Download the version corresponding to your system from the YoupiPaint website.

Run the installer and follow the instructions.

Getting started with the interface

YoupiPaint is a program for making drawings with your computer. For this you have a set of tools and basic
functions:

· Brushes, pencils and other painting tools

· Pallets and colors

· Paper and Layers: A list of drawings that overlap with each other.

The interface of YoupiPaint

Basic concepts
The application offers you a drawing surface materialized by the paper. You draw in layers: layers are
layered one over another. By default, documents have only one layer, but you can add or remove layers at
any time. Layers are displayed from the highest to the lowest. You can decide at any time to change the
order of the layers.
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The interface includes:

· 1: The drawing area.

· 2: A main toolbar for selecting tools such as the brush tool, the selection tool, the shape tool, and so
on.

· 3: Toolbars specific to each tool. They are displayed only when a specific tool is selected on the main
toolbar.

· 4: Panels:

o The list of brushes

o The settings of the brush in use

o The color palette in use

o The color selection panel

o The history of the commands that were performed during the drawing session. These
commands can be canceled.

o The selection panel of an effect applicable to layers.

o The animation mode panel

· 5: The list of layers

Toolbars and panels can be attached or detached by drag and drop. You can position them according to
your wishes. The position of the elements is memorized and will be restored at the next startup.

If you have multiple screens in your configuration, you can position the panels outside the main window.

Tools

Tools can be accessed through the toolbar or through the Tools menu.
 

Brush tool 
This tool allows to draw and paint on the layer in use. YoupiPaint provides a wide variety of pencils and
brushes to simulate painting and drawing techniques.

Selection 
The selection tool allows you to define an area of the drawing in order to restrict operations to this area.

Line tool 
The line tool allows you to draw lines or polygons using the brush in use.

Shape tool 
The shape tool allows you to draw shapes such as rectangles or ellipses and then fill and stroke them.

Fill tool 
The fill tool allows you to fill areas of the same color as the selected color.

Magic wand selection tool  
The magic wand selection tool allows you to select areas of identical color.

Text tool 
The text tool allows you to enter texts, format them and then integrate them into the drawing.
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Gradient tool 
The gradient tool allows you to define gradients from color points and then integrate them into the drawing.

Image tool 
The image tool allows you to select image from a file or from the clipboard if it contains an image and then
to integrate it into the drawing.

Color picker tool 
The color pipette tool allows you to select the color of a point on the screen.

Symmetry tool 
The symmetry tool allows you to draw in mirror mode from the definition of symmetry axes.

Grid tool 
The grid tool displays a grid on the canvas.

Perspective tool  
The Perspective tool lets you display vanishing points and lines to make it easier to draw perspectives.

Comic strip tool 
This tool allows you to draw Comic strip frames.

Ruler tool  
This tool makes it possible to draw lines parallel to a direction.

Basic view manipulations

YoupiPaint allows you to navigate through the drawing with many actions, most of which are accessible with
the mouse.

Zoom
Use the mouse wheel forward to zoom in and out to zoom.

You can also use the corresponding control on the graphics tablets (depending on the tablet type and the
function settings of the tablets).

The zoom is centered on the current cursor position.

You can also use other methods of displaying the workspace. See the Window menu for more information.

Rotation
For more comfort and precision in making your drawings you can rotate the paper 360 degrees.

To rotate the drawing use the mouse wheel forwards / backwards and simultaneously press the Control (Ctrl)
key on the keyboard.

Move View
You can move the view of the drawing sideways or from bottom to top.
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Move with the mouse or the stylus
Perform a drag-drop (drag-and-drop) with the mouse:

· Click the view with the right mouse button

· Move the mouse

· Release the right button

Move with the keyboard keys
To move the view using the keyboard:

· Move the view to the right or left: press the right / left keys

· Move the view up or down: press the up / down keys

· Fast move to right or left: press Ctrl and the right / left keys

· Fast moving up or down: press the page up / down keys

Move with the mouse wheel
To move the view using the wheel:

· Move Sideways: Press Ctrl + Shift and rotate the mouse wheel

· Move from top to bottom: Shift and rotate the mouse wheel

Reset view
To reset the view to its original state:

· Press Ctrl + P to display the drawing view at its original size.

· Press Ctrl + Shift + P to adjust the drawing view to the size of the window.

These functions are also accessible from the window menu

Select a color

The color panel allows you to quickly select a color.
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Panel elements

Color selection area
This area allows you to quickly choose a color by clicking on it with the mouse.

The type of color selected depends on the tool in use and the function keys used simultaneously with the
click of the mouse.

Without key Control key Shift key

Brush Brush color Brush border color No effect

Shapes Fill color Stroke color Gradient color

Texts Fill color Stroke color Gradient color

Panel Type
This list allows you to choose the type of panel displayed.

color
This slider lets you change the hue of the color.

Saturation
This slider allows you to change the saturation (color intensity) of the color.

Value
Use this slider to change the color value (brightness).

Red
Use this slider to change the red component of the color.

Green
Use this slider to change the green component of the color.

Blue
Use this slider to change the blue component of the color.

Type of generator
This list allows you to choose a type of color generator. The color generator creates a series of colors
associated with the chosen color. To select a generated color, click on it with the mouse.

Color History
The color history displays a list of the last colors used in the drawing. You can set the number of colors
displayed in the application settings. To select a color from the history click on it with the mouse.

Select a brush

This panel allows you to select a brush from among the suggested ones. The brushes have a name
displayed below the preview and are organized into groups.
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To select a brush, click on the brush preview.

To find a brush by entering a search text in the search field :

· Enter the text contained in the brush name or in the group.

· Press enter.

· Press the Enter key again to find the next brush matching your search criteria.

Brushes that do not use the standard brush engine are marked in the list with the Fx (Effect) icon.
 
Similarly, brushes operating in eraser mode are marked in the list with an eraser icon.

Brush settings

The brush settings panel allows you to quickly modify all parameters of the brush in use.
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The parameters are organized into categories:

· Preferred settings. The settings for this category are configurable for each brush.

· Size Settings

· Opacity settings

· Shape settings

· Color settings

· Composition settings

· Parameters specific to the brush motor

For more information on the meanings and use of parameters, see the brush topics.

Most of the parameters can be changed with a cursor or for greater precision by entering the value in the
field next to it.

The button  resets the settings to the values   of the last backup.

This button also displays a sub-menu:

· Save the current settings. This operation is not reversible, except for brushes shipped with YoupiPaint.

· Display advanced settings dialog.

Select and apply an effect

This panel allows you to select an effect to apply to the layer in use.
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To select an effect, click the panel and then the Preview button

You can also activate preview mode by double clicking on the effect.

Panel toolbar functions:

·  Add an effect to the list. For more information on this function, see Effects Development

·  Edit the selected effect

·  Duplicate selected effect

·  Remove and delete the selected effect from the list

·  Preview of the selected effect

Manage color palettes

Color palettes allow you to quickly select a color from a predefined list of colors.
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To display a palette, select it from the list.

For pallets supplied with the application, you can edit them during the drawing session (add, delete, or move
colors), but the changes will not be saved.

You can change the color order by dragging and dropping them.

Add a new palette 
Enter the name of the palette and press Ok.

Save modifications 
If you added or deleted colors to the palette, this function allows you to save the changes. You can not
change the default palette shipped with the application.

Duplicate the current palette 
This function creates a new palette by duplicating the colors of the palette in use. Enter the name of the new
palette and press the Ok button.

Delete the current palette 
This function removes the current palette. You can not delete the default palette shipped with the
application.

Add a color 
This function adds the color of the brush to the current palette in the first position of the color list.

Remove a color 
This function removes the selected color from the palette.
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Command history

This panel displays a list of the most recent changes made to the drawing. The displayed changes can be
canceled or re-executed.

To undo or redo one or more changes, click a line in the list. Any changes after or before the selected line
are canceled or redone.

When you make a new change, and the selected line is not the last one, subsequent changes are removed
from the list.

The number of changes can be set in the application options.

Layers

The list of layers is displayed in the drawing window. Layers are displayed in the order from the top (top) to
the bottom (bottom).
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To select the current layer just click on the corresponding thumbnail.

Operations on the current layer by clicking on the icons displayed next to the layer:

· Show / hide the layer: 

· Block / unblock the layer: it is not possible to modify a blocked layer: 

· Edit the properties of the layer: 

If an effect is previewed on the layer, the button  is displayed on the thumbnail of the layer. If you click
this button, the dialog for changing the properties of the effect is displayed.

Edit Layer Properties

On this window it is possible to change the name and the opacity of the layer. A layer whose opacity is less
than 100% will appear more or less transparent.

The contextual menu

The context-sensitive panel provides quick access to the essential functions of the application.

· The properties of the layer

· The history of the colors used

· Quick selection of brush sizes
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· The current color palette

· The list of brushes

To bring up the pop-up panel, press the Ctrl key and click the drawing with the right mouse button.

The contents of the panel can be configured: click on the parameterization icon  and select the display
and transparency options of the panel.
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New file

To create a new document, Select File > New Document

After you have defined the document settings, click Create Document.

Document Creation Dialog

Template
Selects predefined settings. Choose a template from the list (you can create your own templates).

To facilitate the creation of documents with a standard size:

· Click the button next to the template list.

· Choose a standard size from the list

· Change the settings if necessary

· Click the OK button.

Width
Width of the document in pixels
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Height
Height of the document in pixels

Paper Type
Defines the nature of the paper:

· Colored paper

· Paper defined from an image

· Transparent paper (no paper)

Paper Name
Only for papers defined from an image. In this case, the paper will consist of a mosaic covering the drawing
and having as a motif the selected image.

To select a paper:

· Click the button next to the paper name to display the list of available papers.

· Choose a paper from the list

· Click the Select button.

You can also:

· Import a paper by clicking the Add button

· Delete one of the papers from the list by clicking the Remove button.

Note on image sizes for paper: for performance reasons it is preferable to use mosaic patterns of maximum
size 512x512.

Color of paper
Only for colored type papers, allows to choose the background color of the drawing.

Click the Edit Color button to choose a new background color.

Click the Clear Color button to return to the default paper color (white paper).
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Auto extension
Auto-extend allows you to automatically enlarge the size of the drawing to suit your needs even while you
are painting or drawing.

To enable automatic extension, select this option.

Note: If you did not select this option when creating the document, you can set it at any time or decide to
change the paper size and position.

Extension margin
If the auto-extension option is selected, the margin sets the amount of paper added to ensure a border to
the drawing. This border is in pixels.

Functions of the dialog

Create document
Creates a new document from the dialog settings.

Cancel
Aborts and returns to the main window

Save template
Saves the settings in the current template.

Save as
Saves the current settings in a new template.

Screen size
Initializes the width and height data with the dimensions of the screen.

Open a file

Displays the open file dialog.

To open a file:

· Select File menu > Open a file or click the button on the main toolbar

· Choose a file in the dialog and click Open.

· The YoupiPaint files have the file extension "* .ypd".

Save file

This function saves the file being edited.

If the document is saved for the first time, a file save dialog is displayed.

Choose the directory and filename and click Save.

Save file as

This function allows you to save the current document under a different file name.
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To save as:

· Select File Menu > Save As

· Choose destination directory and file name

· Click Save

If the file already exists, a confirmation dialog is displayed.

Import an image file

This function allows you to import an image file into the current layer.

Choose the file in the File Open dialog.

After choosing the file the image tool is activated. You can then position, resize, or rotate the image before
embedding it in the layer.

Export an image file

This function allows you to export all or part of the drawing to an image file.

To export the image:

· Select File menu > Export As Picture

· Set the dialog options

· Click the Ok button

· Choose a path and filename

· Click Ok again

The export dialogue

Width
Enter the desired width of the image in pixels. By default, the width is initialized with the width of the
drawing. If a selection area is active, the width is the width of the selection.

Height
Enter the desired height of the image in pixels. By default the height is initialized with the height of the
drawing. If a selection area is active, the height corresponds to the height of the selection.

Block width / height ratio
If this option is checked, the width / height ratio of the drawing is preserved.
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Export all layers
If this option is checked, all layers are exported, otherwise only the current layer is exported.

Limit to selection
If this option is checked, and a selection is active, only the selection rectangle is exported.

Exporting paper
If this option is checked, the paper is included in the exported image, otherwise only the layers are
exported.

Print

This function is used to print the current document.

To print :

· Select File Menu > Printing

· Set the print options and click the Ok button
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· Click the Print button

Properties

This function displays the properties of the current document:

· The dimensions of the document

· The number of layers

· The color histogram for each channel red, green, blue

Recent files
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This function displays a list of the last 10 opened files.

To open a recent file:

· Select File menu > Recent Files sub menu

· Click on the recent file to open

Quit application

This function closes the current document and closes the application.

If the document has been modified and the changes have not been saved, the confirmation dialog is
displayed:

· Save: the document is saved and the application is closed

· Don't save: Changes are not saved and the application is closed

· Cancel: the application is not closed

Undo, redo

These functions allow you to cancel or redo the last changes.

You can also undo or redo the changes using the Command History panel.

To undo :

· Select Edit Menu > Undo

· Or press Ctrl + Z

To redo:

· Select Edit Menu > Redo

· Or press Ctrl + Y

Copy, cut, paste

If a selection area is active, these functions are used to copy / cut the selection area to the clipboard.

The paste function allows to extract the image present in the clipboard if there is one, and to activate the
Image tool with the contents of this image.

Note: Because image transparency management is specific to each application, the transparency of an
image may not be rendered correctly from the clipboard.

To copy, cut:

· Select a drawing area with the Selection tool

· Select Edit menu > Copy or press Ctrl + C

To paste:
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· Select Edit menu > paste or press Ctrl + V

· The image tool is activated: position the image or you want to paste it

Paste in a new layer

This function is similar to the paste function, but first creates a new layer and pastes the contents of the
clipboard into this new layer.

To paste into a new layer:

· Select Edit menu > Paste in a new layer or press Ctrl + Shift + V

· A new layer is added and activated

Increase or decrease brush radius

These functions increase or decrease the radius of the brush in use.

They can be accessed with the + and - keys on the numeric keypad.

When the radius of the brush is changed, an instruction message is displayed to indicate the new radius of
the brush.

Alternative methods for increasing or decreasing the radius of the brush:

· Display the context panel (Ctrl + right click) and choose the new radius

· Press the Alt key and rotate the mouse wheel forward to increase the radius and back to decrease the
radius

· Display the brush settings panel and adjust the radius slider.

Change paper

This function allows you to change the paper settings of the document.

To change the paper:

· Select Edit Menu > Change Paper

· Change the paper settings in the dialog

· Click Ok
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Paper Change Dialog

Width
Width of the document in pixels

Height
Height of the document in pixels

Lock ratio
Keep the ratio constant width-to-height.

Paper type
Defines the nature of the paper:

· Colored paper

· Paper defined from an image

· Transparent paper (no paper)

Paper name
Only for papers defined from an image. In this case, the paper will consist of a mosaic covering the drawing
and having as a motif the selected image.

Click the button next to the paper name to display the list of available papers.

Choose a paper from the list and click the Select button.

You can also:

· Import a paper by clicking the Add button

· Delete one of the papers from the list by clicking the Remove button.

Note on the image sizes for the paper: the image of the paper is assembled in mosaic to cover the entire
paper. For performance reasons it is preferable to use mosaic patterns with a maximum size of 512x512.
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Paper color
Only for colored type papers, allows to choose the background color of the drawing.

Click the Change Color button to choose a new background color.

Click the Reset button to return to the default paper color (white paper).

Auto extension
Self-expanding paper automatically extends the size of the drawing to suit your needs even while you are
painting or drawing.

To enable automatic extension, select this option.

Note: If you did not select this option when creating the document, you can set it at any time or decide to
change the paper size and position.

Extension margin
If the auto-extension option is selected, the margin sets the amount of paper added to ensure a border to
the drawing. This border is in pixels.

Increase or decrease paper size

These functions increase or decrease the paper size.

When the paper size is changed, an instruction message displays the new paper sizes.

Alternative methods to change the paper size:

· Use the Adjust paper size to the selection feature.

· Display the Change paper dialog.

Adjust paper size to selection

This function allows you to resize the paper visually. This feature makes it easier to crop your drawing.

To change the crop:

· With the Selection tool select the rectangular area that will be the new crop.

· On the Edit menu, click Adjust paper size to selection.

Important notes:

This function does not remove the drawing from the new cropping area, but simply changes the rectangle of
the paper. You can change this area again and find all or part of the drawing that you have hidden.

In the same way, the brush strokes carried out outside the area of   the paper are still recorded by the
application. This makes it possible to reveal these drawings when the area of   the paper is enlarged.

So in summary, you do not have to worry about the initial framing of your drawing. The final framing and
dimension of the drawing are decisions you can take a posteriori.

Clear color history

This function allows you to clear the color history of the color selection panel and the context menu.

A color is added in the color history each time you use a different color on the drawing.
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Color is added to the history only if it is not already present in the history.

By default, 20 colors can be added to the history. Beyond 20 colors the oldest color is removed from the
history and the new color is added.

The number of colors in the color history can be changed in the User settings.

Application settings

This function allows customizing the operation of YoupiPaint.

To change the settings:

· Select Edit Menu > Settings

· Select a parameter category from the list

· Modify the settings then click the Ok button

Note: Changing some settings requires a restart of the application. If this is the case a dialog asks if you
want to restart the application.

The parameters are organized into categories:

· User settings

· Document settings

· Grid settings

· Display settings

· Editor 

· Shortcuts settings

User

To change user settings:

· Select Edit Menu> Settings

· Select Category



YoupiPaint User Manual

30 / 95

Save the layout of the interface
If this option is checked, the layout of the panels and tool bars is stored and restored at the next startup. If
this option is not checked, the default layout is displayed at startup.

User language
Allows you to choose a language for the YoupiPaint interface. If this option is changed, you must restart the
application for it to take effect.

Translate composition modes
If this option is checked, the composition modes of the layers are translated into the language of the user.
Note: If you are looking for information on Internet about composition modes, it is better to keep the English
translation.

Open the last file at startup
If this option is checked, the last file used is reopened at startup.

Show instructions
If this option is checked, help texts are displayed according to the tool in use and the actions performed
with this tool.

Duration of texts
Indicates the display time in seconds of instruction texts



YoupiPaint User Manual

31 / 95

OpenGL Documentation URL
Specifies an URL for OpenGL documentation. This URL can be called from the Effects and Brush Motor
Development window

Color History Size
Indicates the number of colors that appear in the color history of the color selection panel and in the context
menu

Document

To change the document settings:

· Select Edit Menu > Settings

· Select category Document

Default Width
The default width of the document in pixels.

Default Height
The default height of the document in pixels.

Paper Type
Default paper type.
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Color of paper
Default paper color for colored papers.

Paper Name
The default paper name for image type papers

Show transparent paper
If this option is checked, the transparent paper is marked by a checkerboard, otherwise the background of
the document is displayed.

Resolution Unit
Unit used to calculate document dimensions for printing. The density is expressed in pixels per inch or in
pixels per centimeters.

Undo/redo limit  (from 8 to 64 operations maxi)
Maximum number of changes in the change history. YoupiPaint handles undo operations with a disk buffer.
The larger the number of operations, the greater the buffer size.

Undo/redo memory size
Specifies the size of the memory allocated for the cancellation of commands in megabytes, min 256 MB,
max 1024 MB. When the allocated size is reached the application uses the disk cache to perform the undo
operations.

Auto document extension
The default option for auto-extending the document. For more information on automatic document extension,
see New file.

Drawing margin
In case auto-extension is enabled, indicates the value in pixels of the drawing border.

Background color of the document
Sets the background color of the document. To change the color click on the button and choose the new
color in the dialog.

Grid

To change the grid settings:

· Select Edit Menu > Settings
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· Select category

Grid size
Sets the size in pixels of the grid displayed over the drawing.

Show grid
If this option is checked, the grid is visible.

Grid color
Indicates the color of the grid lines. To change the color click on the button and choose a color in the dialog
displayed.

Align to grid
Indicates whether to align the moved objects on a grid. This function can be activated by function keys.
Refer to the tools topics to see how to enable or disable alignment using the function keys.

Align to grid size
Indicates the size in pixels of the alignment grid.

Display

To change the display settings:

· Select Edit Menu > Settings
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· Select category Display

Smooth pixels
If this option is checked, the display of the drawing is softened to the lower scales or greater than the
original size.

Smooth until the zoom reaches X
Indicates the value of the zoom beyond which the pixels of the drawing are displayed in a grid.

Show thumbnails
If this option is checked, the thumbnails of the layers are displayed in the interface.

Show thumbnails names only
If this option is checked, only the layer names are displayed in the layer list, except for the current layer.

Thumbnail size
Sets the size in pixels of the layer thumbnails.

Thumbnail opacity
Sets the opacity with which layer thumbnails are displayed.

Thumbnail color
Sets the background color of thumbnails of layers.
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Thumbnail  selection color
Sets the thumbnail color of the layer being used.

Thumbnail  position
Indicates the position of the thumbnail display (up, down, right, left).

Show tiling
If this option is enabled, the document is repeatedly displayed in a tiling. This option is useful for displaying
borderless textures.

Editor

To change the code editor settings:

· Select Edit Menu > Settings

· Select the Editor category

Tab Size
Indicates the size in number of tab characters.

Font name
Name of the font used by the editor.
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Font size
Size of the font used by the editor.

Smart tab
If this option is checked, tabs are added if necessary when creating a new line in the editor.

Shortcuts

Almost all YoupiPaint functions can be accessed using keyboard shortcuts.

To change the shortcuts:

· Select Edit Menu > Settings

· Select the Shortcuts category 

To change the shortcut assigned to a function:

· Select the function you want to modify in the table and click on the Modify button

· Or double click on the function to modify

· In the edit dialog, tap the key combination that you want to assign.

· The shortcut is automatically displayed.

· Click Ok



YoupiPaint User Manual

37 / 95

If the combination you have chosen is already assigned to another function, a warning dialog is displayed.

In this case, if you validate, the shortcut is removed from the original function and then assigned to the
function you modified.

Default Button
Resets the shortcut to its default value.

Reset Button
Resets the shortcut to its last saved value.

Ok Button
Assigns the new shortcut to the function.

Cancel button
Abort without changing the shortcut.

Reset Button
Resets the shortcut to its default value.

Reset All button
Resets all shortcuts to their default values.

Copy button
Copies the table of functions with an assigned shortcut to the clipboard. Useful for printing a summary of
function keys.

Selection

The selection consists of defining one or more areas of the drawing so that the modifications you make are
reduced to this area.

To define a selection area use the Selection tool. This tool offers many ways to select an area.

You can also copy, cut and paste the selected area.

Select all

This function allows you to select the entire document. The area defined by the paper rectangle is selected.

To select everything:

· Select Selection Menu> Select All

Invert selection

This function selects all unselected parts.
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To reverse the selection:

· Define a selection area with the Selection tool

· Select Selection Menu > Invert Selection

Reset selection

This function reset the active selection.

To reset the selection:

· Select Selection Menu > Reset Selection

Fill selection

This function is used to fill the selection area with the current color.

To fill the selection:

· Set the selection area

· Choose a color

· Select Selection > Fill Selection

· Alternative method: click the icon  in the Brush toolbar or Selection toolbar

Stroke selection

This function draws a brush stroke on the contour of the active selection area.

To draw the outline of a selection area:

· Select the area to be drawn

· Select a brush

· Select a color

· Select Selection Menu > Stroke selection

· Alternative method: click the icon  in the Brush toolbar or Selection toolbar

To draw manually on the outline of the selection:

· Check the option to Follow path in the Brush toolbar.

· If this option is checked, the brush strokes are automatically centered on the contour of the selection
area.

Next, previous selection

The selection fields are historized. You can re-enable a selection from the history.

To reactivate a selection:

· Select Selection menu > previous selection: reactivates the previous selection in the history.

· Or select Selection menu > next selection: reactivates the next selection in the history.
 

Layer

Layers are drawing surfaces stacked one on top of the other.

The layers are transparent by default and are positioned over the paper. An area of   one layer below another
is visible by transparency, provided that the layer above does not overshadows this area.
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You can change the opacity of a layer to reveal layers below it.

Layers are displayed by default to the left of the drawing area, from the highest layer to the lowest layer.

To select a layer, click the thumbnail of the layer. When a layer is selected, drawing operations and effects
are applied to that layer.

If the window is not large enough to display all the layers you can move around the list.

To scroll through the list of layers:

· Position the mouse over the layer display area

· Drag and drop to the top or bottom

· Or turn the mouse wheel

Here, for example, 3 layers, the layer selected is the middle layer, the other layers are displayed with a gray
background:

You can change the display position of the layers in the Display sttings .

The layer toolbar

 
Add a layer

Remove selected layer

Edit layer properties

Duplicate the selected layer

Move the selected layer up

Move the selected layer down

Show / Hide the selected layer
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Lock/unlock the selected layer

Change the properties of the effect applied to the layer

Select next layer

Select previous layer

Show timeline mode 

Add a layer to the top

This function allows you to add a layer at the top of the stack and to select the layer added.

To add a layer at the top of the stack:

· Select Layers menu > Add a layer at top

· Or click on the button   of the Layer toolbar

Add a layer to the bottom

This function adds a layer at the bottom of the layer stack and selects the added layer.

To add a layer at the bottom:

· Select Layers menu > Add a layer at bottom

Edit layer properties

This function allows you to modify the properties of the layer.

To modify the properties of the layer:

· Select Layers menu > Edit layer

· Or click on the button  of the Layer toolbar.

· Alternative method: Click on the button  located next to the thumbnail of the layer.

The layer properties dialog is displayed:
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The layer properties dialog

Name
Layer name.

Opacity
Sets the transparency of the layer. A semi-transparent layer lets you see the layers that are below it. To
change the transparency, change the cursor position or enter the opacity percentage for more precision.

Visible
Indicates whether the layer is visible or hidden. An invisible layer can not be changed. When the layer is not
visible, a warning message is displayed in the work area.

Locked
Indicates whether the layer is editable. A blocked layer can not be edited. When the layer is blocked, a
warning message is displayed in the work area.

Mask
If this option is enabled, the layer acts as a mask for the layer above it. Brushes drawing in the layer above
will inherit their transparency from the mask layer.

Possible values:

· No mask: normal mode

· Alpha mask: the transparency of the layer is multiplied to the transparency of the brush

· One minus alpha mask: the transparency of the brush is multiplied to one minus the transparency of the
layer (reverse mask)

Edit effect properties

If an effect is applied to the layer, this function allows you to modify the effect parameters.

To change the settings:

· Select Layers Menu > Edit layer effect

· Or click on the button  in the Layers toolbar

· Alternative method: click on the button  located in the thumbnail of the layer

Remove layer

This function deletes the current layer from the layer list.
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To delete the layer:

· Select Layers menu > Remove layer

· Or click on the button  in the Layers toolbar

Duplicate layer

This function allows you to create a new layer and copy the contents of the current layer into this new layer.

To duplicate the layer:

· Select Layers Menu > Duplicate layer

· Or click on the button  in the layers toolbar

Show/hide layer

This function displays or hides the current layer.

When the selected layer is hidden it can not be changed, a warning message is displayed in the work area
and the cursor becomes .

To show / hide the layer:

· Select Layers menu > Layer visibility > Show / hide layer

· Or click on the button  in the Layer toolbar

· Alternative method: click on the button  next to the thumbnail of the layer

Lock/unlock layer

This function locks or unlocks the current layer.

When the selected layer is locked it can not be modified, a warning message is displayed in the work area

and the cursor becomes .

To lock / unlock the layer:

· Select Layers menu > Layer visibility > Lock / unlock layer

· Or click on the button  in the Layer toolbar

· Alternative method: click on the button  next to the thumbnail of the layer

Show all layers

This function makes visible all the layers that have been hidden.

To display all layers:

· Select Layers menu > Layer visibility > Show all layers

Hide all layers

This function hides all visible layers.

To hide all layers:

· Select Layers menu > Layer visibility > Hide all layers
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Lock all layers

This function lock all unlocked layers.

To lock all layers:

· Select Layers menu > Layer visibility > Lock all layers

Unlock all layers

This function unlocks all locked layers.

To unlock all layers:

· Select Layers menu > Layer visibility > Unlock all layers

Next layer

This function selects the layer following the current layer.

To select the next layer:

· Select Layers Menu> Layer visibility> Next layer

· Or click on the button  in the Layer toolbar

Previous layer

This function selects the layer before the current layer.

To select the previous layer:

· Select Layers menu > Layer visibility> Previous layer

· Or click on the button  in the Layer toolbar

Merge layer with upper

The merge operation consists of taking 2 or more layers and combining their drawing into a single layer. The
new layer replaces merged layers.

To merge the current layer with the layer above:

· Select Layers Menu > Merge with upper

Merge layer with lower

The merge operation consists of taking 2 or more layers and combining their drawing into a single layer. The
new layer replaces merged layers.

To merge the current layer with the layer below:

· Select Layers Menu > Merge with lower
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Move up

This function moves the current layer one position up the stack.

To move the layer up:

· Select Layers Menu > Move up

· Or click on the button  in the Layer toolbar

Move down

This function moves the current layer one position down the stack.

To move the layer down:

· Select Layers Menu > Move down

· Or click on the button  in the Layer toolbar

Remove empty layers

This function removes all layers that do not contain any drawing.

To remove the empty layers:

· Select Layers menu > Remove empty layers

Time line

Animation mode allows you to display the layers frame by frame. Each layer contains a frame of the
animation and when the animation is launched YoupiPaint displays the images at regular intervals.
Animation mode allows you to display one or more images prior to the current image in order to better see
the transitions between two images.

To display the animation dialog:

· Select Layers Menu > Timeline

· Or click on the button   in the Layer toolbar

The animation dialogue
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Returns to the first image

Step backward

Step forward

Go to the last image

Runs animation

Stop animation

Slider Allows you to animate frame by frame. To change the image, drag the cursor.

Show previous
frame

If this option is checked, the image preceding the current image is displayed in the
background.

Frame rate Number of images displayed by interval time

Interval duration Duration of the animation interval in milliseconds. For example: frame rate = 3 and duration
= 1000 => 3 frames per second.

Export
directory

Directory in which images of the animation are saved

File name
prefix

Prefix added to the name of the export files

Add date/time
to prefix

If this option is checked, the date and time are added to the prefix

Export in
reverse order

Exports images in reverse order: top layer is number 1 else bottom layer is number 1

Exporting images
This function allows you to create a series of images from the layers of the drawing, an image is generated
per layer.

To export images:

· Enter an export directory and a format for the file name prefix

· Click on the button  in the toolbar

The prefix is   appended to the image file name. For example: "image-" will produce the following filenames:

· image-0001.png

· image-0002.png

· image-0003.png

· ...

If the Add date and time to prefix option is checked, the filenames produced are:

· image-2017_05_26_15_34_23_0001.png

· image-2017_05_26_15_34_23_0002.png

· image-2017_05_26_15_34_23_0003.png

· ...

Performance Considerations

It is important to note that the more layers in the drawing, the more the performance of YoupiPaint will be
impacted.

To ensure good performance, a choice must be made between:

· Little layer number and large layer sizes

· Many layers of smaller dimensions
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Other elements also have an impact on performance:

· The size of the brush. A big radius consume more resource.

· Layers thumbnail view. When there are many layers it is preferable to display only the thumbnail of the
current layer.

Brush

The brush tool is one of the main tools of YoupiPaint. It is with this tool that you draw with a pencil or a
brush.

YoupiPaint offers a multitude of brushes simulating traditional drawing tools.

You can select a brush from the brush panel.

Changing brush settings

This function displays the dialog for changing the brush settings.

To change the settings:

· Select Brush Menu > Edit brush settings

· The dialog is displayed, adjust the settings

You can also display this dialog by clicking the Advanced Settings button  of the brush settings panel
menu.

If you want to save the changes you made, click the save button  . If you leave the dialog without saving
the changes you made, a confirmation dialog is displayed:

· Keep changes without saving: the changes remain active until the next start. They are canceled if you
reset the settings to the value of the last backup.

· Abort and close: changes are not applied.

· Do not close: remain on the dialog.

Basic principles of brushes

The brush strokes consist of the juxtaposition of marks stamped on the drawing with regular spaces:
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The marks are of 2 types:

· Elliptical or rectangular shape marks.

· Marks created from an image used as a mask: in this case we speak of brush texture.

The brush engine is responsible for calculating the marks of the brushes.

Spacing, shape, diameter, opacity and many other parameters can be modulated by the brush engine.

The calculation of the brush marks takes into account many input parameters such as the pressure exerted
by the stylus on the graphics tablet. A characteristic use of this type of parameterization, called brush
dynamics, consists in varying the radius of the brush mark as a function of the pressure. This dynamic is
done by a curve of response of the radius with respect to the pressure.

To access the brush dynamics curve settings, click the button next to the parameter you want to change:

· If the parameter is associated with one or more curves,  

· If the parameter is not associated with any curve,  

For more information on setting the brush dynamics, see this topic.

For more information on the development of brush engines, see this topic.

Brushes with texture

The menu of the texture button  allows to manage the texture of the brush:

· Load brush texture: allows you to change the image used for the brush texture.

· Remove brush texture: Remove the texture associated with the brush. In this case the brush mark is
fully calculated by the brush motor.

· Export texture: This function allows you to save the brush texture in an image file.

Standard brush settings

Parameter Description min max

Settings for Size category
Radius Radius in pixels of brush mark. 0.1 1000

Spacing Pixel spacing between each mark of the brush. 0.01 500

Spacing type Type of mark spacing.

Possible values:

· Auto Spacing: the brush engine automatically
calculates spacing between marks

· Ratio-type spacing: a ratio to diameter is specified.
For example, a ratio of 3 for a brush having a radius of
10 pixels causes a spacing of 30 pixels between the
marks.
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· Constant Spacing: In this case, the spacing indicates
a fixed value in pixels.

Minimal disptance Minimum distance in pixels between 2 marks of the brush. 0.2 30

Accumulation distance Distance of the path taken by the mouse from which the
brush engine starts to run the brush stroke. Before this
distance the events are recorded but are not executed.
This parameter may be useful for making the calculation of
the angle of the brush, for example, more reliable.

0 500

Offset x Mark offset along the horizontal axis. 0 1

Offset y Mark offset along the vertical axis. 0 1

Settings for Opacity category
Flow Opacity of marks. 0% 100%

Opacity Opacity of the brush stroke. Unlike the flow, the opacity
applies to the entire stroke while the flow applies to each
mark.

0% 100%

Hardness The hardness defines the sharpness with which each mark
is made.

0% 100%

Pixels density The density of pixels defines the amount of pixels
deposited by the brush on the layer. For example, brushes
of the airbrush type have a low density.

0% 100%

Antialiasing Antialiasing, or smoothing, is a method to avoid aliasing, a
phenomenon that occurs when viewing certain images with
a high zoom.

Possible values:
Antialiasing: the marks are smoothed.
No antialiasing: the marks are not smoothed.
Softening: brush marks with textures are softened
according to the zoom.

Eraser mode The eraser mode makes it possible to transform the brush
into eraser.

Settings for Shape category
Shape Shape of the brush mark.

Possible values:

· Ellipse

· Rectangle

Ratio Mark height / width ratio. 0.1% 10 000%

Angle Angle in degrees from the mark axis to the horizontal. -180 +180

Angle type Type of angle of mark.

Possible values:

· Constant angle: the angle is constant regardless of
the direction taken by the brush.

· Follows the direction: the angle is calculated with
respect to the direction taken by the brush. Example:
see the roller brush.

Settings for Color category
Color absorption rate The color absorption rate indicates the amount of color of 0% 100%
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the layer transferred to the brush. Typically this parameter
is used to simulate brushes such as oil painting or
watercolor on wet paper.

Color flow rate Unlike the absorption rate, the rate of color flow indicates
the amount of color deposited on the layer by the brush.

0% 100%

Preserve texture color For texture type brushes, if this option is checked, the
original color of the texture is preserved. Otherwise, the
mask of the texture is filled with the color of the brush.

Use border color The standard brush engine can use 2 types of colors: the
color of the mark and the color of the border of the mark. If
this option is checked, the engine applies a color gradient
from the center to the border of the mark using these two
colors.

Hue Tint offset of the color. -1 1

Saturation Saturation offset of the color.. -1 1

Value Value offset of the color. -1 1

Border hue Offset of the tint of the border color -1 1

Border saturation Offset of the saturation of the border color -1 1

Border value Offset of the value of the border color -1 1

Settings for composition category
Mode Mixing mode of the color of the layer with the color of the

brush.
Possible values: see details of Composition modes

Inherit transparency of
current layer

If this option is checked, the brush inherits the
transparency of the current layer. The layer acts as a
mask.

Inherit transparency of
layer under current.

If this option is checked, the brush inherits the
transparency of the layer below the current layer.

Factor Factor applied in composition formulas. 0% 100%

The dynamics of brushes

The brush dynamics consists in varying the parameters of the brush according to values   provided by the
application.

For example, a typical case of the brush dynamics is to vary the diameter of the brush as a function of the
pressure exerted by the stylus on the graphic tablet: the lower the pressure and the lower the radius, and
conversely the higher the pressure and the larger the radius.

This behavior can be transposed to actual paint tools such as brush or pencil. The dynamics of the brushes
therefore make it possible to simulate the behavior of the drawing tools.

This dynamic is represented by a curve of response of the brush to an input parameter. Each brush can
have as many curves as there are input parameters.

Input parameter values   are given to each event on the graphic tablet or the mouse.

To display the dynamic curve dialog:

· Affichez le dialogue des paramètres de brosse

· Click on the button  or  located to the left of the brush parameter to be modified.
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The title of the dialog recalls the brush parameter whose dynamic is being modified.

To display a curve associated with an input parameter, click the left panel. Input parameters already
associated with a curve are highlighted.

To modify the curve, move, add or remove points from the curve.

The input parameters

Parameter Description min max
Pressure Pressure exerted by the stylus. Always 1 for the mouse. 0 1

Tangential pressure Tangential pressure of an airbrush. Always 0 for the
mouse.

0 1

Inclination x Inclination in degrees of the stylus along the x-axis.
Always 0 for the mouse.

-60 +60

Inclination y Inclination in degrees of the stylus along the y-axis.
Always 0 for the mouse.

-60 +60

Position x Offset in pixels relative to the position of the mouse or
stylus along the x-axis

-100 +100

Position y Offset in pixels relative to the position of the mouse or
stylus along the y-axis

-100 +100

Direction x Direction of the mouse or stylus trajectory along the x-axis
(normalized vector).

-1 1

Direction y Direction of the mouse or stylus trajectory along the y-axis
(normalized vector).

-1 1

Speed The speed of the mouse or stylus in pixels / milliseconds. 0 100
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Time since previous The elapsed time in milliseconds from the previous mouse
or stylus event.

0 100

Total time The elapsed time in milliseconds since the start of the
stroke.

0 10 000

Distance to previous The distance traveled in pixels by the mouse or stylus
since the previous event.

0 80

Total distance The total distance traveled in pixels by the mouse or
stylus since the beginning of the stroke.

0 1 000

Random Random value changed at each mouse or stylus event. 0 1

Stamps count Number of marks made since the beginning of the stroke. 0 10 000

Add a curve
To add a curve:

· Select a parameter in the left panel

· Click the Add curve button

The curve added depends on the type of curve selected. Once the curve is added, move the points to adjust
to the desired dynamics.

Remove curve
To delete a curve associated with an input parameter:

· Select the input parameter on the left panel

· Click the Remove curve button

Add a point
To add a point to the curve, click the Add point button. Each curve can have a maximum of 6 control points.

Remove point
This button deletes the last point of the curve.

Reset
Resets the points on the curve. The shape of the curve depends on the type of curve selected.

Invert x
Used to invert the curve along the x-axis.

Invert y
Used to invert the curve along the y-axis.

Curve type
The curve type defines the shape of the curve when it is created or reset. Choose a shape from the list.

Formula
The formula defines the type of calculation that the brush engine performs when interpreting the curve.

· Add: after interpretation of the curve, the result is added to the basic value of the brush parameter.

· Multiply: after interpretation of the curve, the result is multiplied with the basic value of the brush
parameter.

· Sinus: the curve is a sinusoid, the result is multiplied with the basic value of the brush parameter.
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Modulo
The modulo is applied to the input parameter. For example, a modulo of 50 pixels applied to the distance
traveled gives an input parameter of 25 pixels for a distance traveled by 75 pixels. In other words, the
distance traveled carries out a cycle of 50 pixels.

x min et x max
Minimum and maximum values   of the input parameter. These data are given as an indication and are not
modifiable.

y min et y max
Minimum and maximum value of the curve. By default the curves are contained in the interval [0, 1], but to
print a strong or weak dynamic this interval can be extended or reduced.

Blending

The composition mode or blending mode of the brushes defines the method of mixing the color of the brush
with the color already present on the current layer.

Most blending mode are standardized and used by image processing applications. You can display the list
of blending modes in English or in your native language.

To display the modes in English:

· Select Edit Menu> Settings

· Display category

· Uncheck Translate composition modes

Description of blending modes

Nom Description
Normal Default composition mode. Mixing the color of the brush and the

color of the layer according to the opacity.
Foreground in The color is deposited only on the parts of the layer where there is

already a color.

Foreground out The color is deposited only on the parts of the layer where there is
no color.

Plus The color of the brush is added to the color of the layer: each red,
green and blue component of the color of the brush is added to the
red, green and blue component of the color of the layer. This mode
of composition brightens the color.

Multiply The color of the brush is multiplied with the color of the layer: each
red, green, blue component of the brush color is multiplied
respectively to the red, green and blue component of the color of
the layer. The color of the brush is not removed if there is no color
on the layer and the colors are darkened.

Screen Same effect as Multiply mode, but the colors are enlightened.
Overlay This mode combines Multiply and Overlay mode. The darker parts of

the layer become darker and the light parts brighter.
Darken This mode darkens the colors by retaining only the darkest color

between the color of the brush and the color of the layer.
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Lighten This mode brightens the colors by retaining only the lightest color
between the color of the brush and the color of the layer.

Color dodge This mode intensifies colors and contrasts, it brightens the colors.
Color burn This mode intensifies the contrast and darkens the colors.
Hard light Highly intensifies light.

Soft light Lightly intensifies light.

Difference This mode performs the arithmetic difference of the 2 colors.
Exclusion Effect similar to difference but with less contrast.
Darker This mode takes the darker of the two colors.
Lighter This mode takes the brightest of the two colors.
Vivid light Eliminates or darkens the color depending on the gray level of the

brush color.
Pin light Creates an illumination effect.

HSL hue Creates a color with the hue of the brush and the saturation and
luminance of the layer.

HSL saturation Creates a color with the saturation of the brush and the tint and
luminosity of the layer.

HSL luminosity Creates a color with the brightness of the brush and the saturation
and hue of the layer.

Dodge highlights This mode intensifies the colors and contrasts of the illuminated
areas, it brightens the colors.

Burn highlights This mode intensifies the contrast of the illuminated areas and
darkens the colors.

Dodge midtones This mode intensifies the colors and contrasts of medium tones, it
brightens the colors.

Burn midtones This mode intensifies the contrast of medium tones and darkens the
colors.

Dodge shadows This mode intensifies the colors and contrasts of the shaded areas, it
brightens the colors.

Burn shadows This mode intensifies the contrast of the shaded areas and darkens
the colors.

Reset brush settings

This function resets the brush settings to the last saved values.

To reset the settings:

· Select Brush Menu > Reset brush settings

· Or click on the button  of the brush settings panel

· Or click on the button  of the Brush toolbar

New brush

This feature adds a brush to the brush list.

To create a new brush:
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· Select Brush Menu > New brush

· Enter a group name to create a new group or select an existing group from the list

· Enter the name of the brush

· Click the OK button

Remove brush

This function removes the selected brush from the brush list and delete the brush. This operation can not be
canceled. 

Note: You can not delete the system brushes (brushes supplied with the application) but you can remove
them from the brush panel. See Sort brushes topic.

To remove a brush:

· Select Brush Menu > Delete brush

· Confirm the deletion by clicking the Ok button

Duplicate brush

This function creates a new brush by duplicating the brush selected in the brush list.

To duplicate a brush:

· Select the brush to be duplicated from the list of brushes

· Select Brush Menu > Duplicate brush

· Enter the group

· Enter the name of the brush

· Click the OK button

Rename brush

This function allows you to change the name of the selected brush in the list.

To rename a brush:

· Select Brush Menu > Rename brush

· Enter the new group

· Enter the new name

· Click the OK button

Load brush texture

This function allows you to load the brush texture on the fly.

To change the texture of the brush:

· Make Brush Menu > Load brush texture

· Choose an image file in the File Open dialog

Sort brushes

This function allows you to change the content of the brush panel and the display order of the brush list.

To sort brushes: Select Menu > Sort brushes.
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The brushes in the brush list are displayed in the left panel. Brushes excluded from the brush list are
displayed in the right panel.

To move the brushes in the list:

· To move up a brush in the list click on 

· To move down a brush in the list click on 

· To put the brush at the top of the list click 

· To put the brush at the bottom of the list click 

To add or remove brushes from the list

· To remove a brush from the list, select it in the left panel and click >, the brush is moved to the right
panel

· To add a brush to the list, select it in the right panel then click <, the brush is moved in the left panel

· To remove all brushes click >>

· To add all brushes click <<

When your changes are complete, click the OK button

Change quick settings

This function allows you to change the list of parameters displayed in the Settings panel in the Preferred
Settings category.

To display the quick settings dialog:

· Select Brush Menu > Edit brush quick settings

· The list of parameters in the category is displayed in the left panel.

· The list of parameters to add is displayed in the right panel.
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· To add a parameter: Select the parameter in the right panel and click <

· To remove a setting: Select the setting in the right pane and click >

· To add everything: click <<

· To remove everything: click >>

· To reset the list to its default value: click Default

· To move a parameter at the top of the list click on 

· To move up a parameter in the list click on 

· To move down a parameter in the list click on 

· To move a prameter at the bottom of the list click on 

Import a brush file

This feature allows you to add a brush to the brush list by importing a brush file.

To import a brush:

· Select Brush menu > Import brush file

· Select the file in the File Open dialog

· The brush is added at the end of the list.

Reset Settings

This function resets the brush settings to their original value. This function can only be used for brushes
delivered with the application. For personal brushes, you can only reset settings to the last saved ones.

To reset the settings:

· Select Brush Menu > Restore brush to system default

Selection to brush

This function creates a brush using the selected drawing portion as the brush's texture.
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To create a brush:

· Draw a brush texture on an empty layer

· Make Menu Brush> Save selection as textured brush

· If the selection is empty, the dialog automatically selects the portion of the drawn layer

· Define the parameters of the brush

· Click Ok

Brush options 

Apply to the
current brush

The texture of the brush is added / replaced by the drawing of the layer

Create a new
brush

If this option is checked, a brush is created and added to the brush list

Group/name of
the brush

Enter the group and the name of the brush

Width/height Width and height of the brush texture in pixels

Ratio Indicates the ratio to the initial size of the selection. A better rendering is obtained for a
ratio of 1. In this case the original drawing is not distorted.

Texture color Choose from the values:

· Brush color: The color of the brush is the color selected in the color panel

· Color of the texture: the original color of the texture is preserved
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· Mix color of the brush / color of the texture: the color is a mix of the selected color
and the original color of the texture

Note: this parameter can be modified later in the brush setting.

Capture all layers If this option is checked, the drawing of all layers is merged into the brush texture,
otherwise only the current layer is used.

Capture paper If this option is checked, the paper is included in the drawing of the brush texture.

Note: This option should not be checked if the paper is completely opaque because in
this case the texture is a full image of the selection.

Effects

YoupiPaint allows you to add effects to your drawings. The effects transform, improve the drawing by
modifying for example the contrast, the brightness or the tint of the colors. YoupiPaint comes with many
effects but If the standard effects are not enough, you can modify them or create new effects.

The effects are applied to the current layer. If a selection area is active, effects are limited to this area.

The list of available effects is displayed in the effect panel.

Overview of effects

Previewing an effect means applying the effect to the current layer temporarily. This function allows you to
see the result in the drawing without modifying the drawing.

Applying the effect consists of modifying the layer by transferring the result to it.

To apply an effect:

· Select the effect in the effects panel

· Select Effect Menu> Preview effect or double-click the effect in the effects panel

· The effects dialog is displayed

· Depending on the effect and if it has settings, the parameters can be changed in the dialog

· Change the settings and click Preview or Apply.

· To remove the preview, click Remove.

If a preview is active in the current layer:

· The use of a brush deactivates the effect for the duration of the stroke.

· An icon  is displayed in the thumbnail of the layer. By clicking on this icon, you display the preview
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dialog of the effect

Show / Hide preview

If an effect preview is active in the current layer, this function displays or hides the preview of the effect.

To show / hide preview:

· Select Menu Effect > Show/hide preview

· This function is accessible with the shortcut Ctrl + J

Remove preview

If an effect preview is active in the current layer, this function removes the preview from the effect.

To remove the preview:

· Select Menu Effect > Remove preview

· Or display the effect dialog and click Remove

Apply effect

Applying the effect involves transferring the preview to the layer. This operation is reversible with the undo
function.

To apply the effect:

· Select Effects Menu > Apply effect

· Or display the effect dialog and click Apply

Import an effect

This function allows you to add an effect by loading it from a file.

To import an effect:

· Select Effect Menu > Import effect

· Choose the file in the File Open dialog

· If the file is loaded properly, a dialog asks if you want to edit the source of the effect. Refer to the
development topics for more information.

Effect thumbnail

This function refreshes the thumbnail associated with the effect and displayed in the effects list. The best
dimension for the thumbnail is 64x64 pixels.

You can :

· Show the standard thumbnail.

· Set the thumbnail of the effect. Assign the canvas drawing as a thumbnail for the effect.

The best way to create a thumbnail for your effects is to display the standard thumbnail: A standard 64 by
64 pixel image is loaded into the canvas. You can modify this image, in particular by treating it with your
effect in order to create a preview which will facilitate the search of the effect in the list. Once you are
satisfied with your thumbnail, use the Set Thumbnail function.

Brush tool

The brush tool allows you to draw and paint on the layer in use. YoupiPaint provides a wide variety of pencils
and brushes to simulate painting and drawing techniques.

To perform a stroke:

· Select the brush tool from the main menu bar
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· Select a brush in the brush panel

· Click the current layer, move the mouse or stylus, release the mouse.

To change the radius of the brush in progress:

· Press the Alt key and rotate the mouse wheel forward to increase the radius

· Press the Alt key and rotate the mouse wheel backward to decrease the radius

When changing the radius, a temporary message is displayed to indicate the value of the new radius.

To draw lines:

· Press the Control key simultaneously by clicking on the layer to define the starting point of the line

· Move the mouse to set the end point of the line

· Click on the layer again to finish the line

To select an area:

· Simultaneously press the Shift key by clicking on the area to be delimited.

· The area is selected using the parameters of the Magic Wand tool

The Brush Toolbar

          

Erase mode: by clicking on this button, the brush is transformed into an eraser.

Fill the selection. If a selection is active, fills the selection with the color of the brush.

Outline of the selection. If a selection is active, draw a line on the outline of the selection
with the brush and the current color.

Blocking of control points. Blocks the movement of the control points of the symmetry and
perspective tools.

Resets the brush settings to their default values.

Follow the
path

If a selection is active and this option is checked, the brush stroke automatically follows the
contours of the selection.

Select a brsuh

The Select Brush menu contains a list of the top 10 brushes in the brush list. You can select one of these
brushes using a function keys.

To select a brush:

· Select Brush Menu > Select Brush

· Choose the brush from the menu

· Or press the Ctrl key and the number of the brush (0 to 9) simultaneously.

Note: You can change the order of the brushes with the Sort Brushes function. The menu is changed after
the application restarts.

Selection tool

A selection consists of one or more areas of the drawing and allows drawing operations to be restricted to
these areas. The selections can also be copied to the clipboard and pasted into the drawing. The selection
tool allows to define zones of various format. The selections are stored in a history and it is possible to
recall a selection of this history.
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When a selection is active, a message is displayed at the top of the drawing area.

To make a selection:

· Choose the selection tool   in the main toolbar.

· Choose the selection settings from the Selection toolbar.

· Click on the drawing, move the mouse, release the mouse.

· For Polygon and Curve selections, click as many times as you want to add points to the polygon or
curve and click the 1st point to close the selection.

· For star-shaped selections it is possible to move the control points to change the shape of the selection

Keyboard shortcut:

· For Polygon or Curve selections, the Backspace key or Ctrl + Delete allows you to delete the last point
added

· The Enter key is used to terminate polygon or curve selections without having to click on the first point

· The Escape key cancels the current selection operation.

The Selection Toolbar

Fill the selection. If a selection is active, fills the selection with the color of the brush.

Outline of the selection. If a selection is active, draw a line on the outline of the selection with
the brush and the current color.

Select all. Selects all paper

Invert selection. 

Deselect. If a selection is active, it is reset.

Previous selection. If several selections have been made, this button recalls the previous
selection.

Next selection. If several selections have been made, this button recalls the next selection.

Forme de
la
sélection

This combo box allows you to define the shape of the selection:

· Rectangle: rectangle-shaped selection

· Ellipse: ellipse-shaped selection

· Polygon: selection defined by a polygon of n points

· Curve: selection defined by a rounded polygon of n points

· Star: star-shaped selection. The number of branches is adjustable in the toolbar

· Rounded star: rounded star-shaped selection.

· Free selection: shape defined by a freehand trace.

Mode de
fusion

This combo box makes it possible to choose the mode of combination of the selection zones:

· Replace: the new selection replaces the current selection

· Add: the new selection is added to the current selection, the common fields are merged.

· Subtract: the new selection is removed from the current selection, the common zones are
removed.

· Intersection: the new selection is added, only the common parts with the current selection
are kept.

Branches Sets the number of branches of star-shaped selections.
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Line tool

The Line tool lets you draw straight lines,  polygons or curves using the current brush and the current color.

To draw a line:

· Select line tool   in the main toolbar.

· Click on the drawing to start the line or the polygon.

· Click the drawing again to finish the line or add a point to the polygon.

· To delete the last point on the polygon, press the Backspace key or Ctrl + Delete.

To finish a polygon or a curve, you can use several alternative methods:

· Simultaneously click the Ctrl key at the same time that you click the drawing to add the last point and
complete the polygon.

· You can also press the Enter key to set the last point at the cursor position and end the polygon.

· Double click to add the last point and complete the polygon.

To adjust the slope of the line to an integer value:

· Adjust the value of the angle offset, the angle of the lines is a multiple of the angle offset.

· Press the Ctrl key as you move the mouse cursor.

To cancel the current construction, press the Escape key.

The Line toolbar

Line type Type of figure:

· Line

· Polygon

· Curved Polygon

Close figure If this option is checked, the polygons are closed by joining the first point and the last
point.

Hand drawn
lines

Modifies the style of the lines by introducing a slight tremor to imitate a line that would be
drawn freehand.

Angle offset Defines the value of the angles of the lines: the angle of the line is measured in degrees
with the horizontal and is a multiple of the angle offset. For example if the offset is 10
degrees the angles of the lines will be 10, 20, 30 degrees, ...

Shape tool

The shape tool makes it possible to draw varied figures, to fill them with a color or a gradation of colors and
to trace their outline.

To add a shape:

· Select the Shape tool on the main toolbar, a shape appears on the center of the drawing

· To move the shape, drag and drop it.

· Using the handles change the size or change the rotation of the shape.

· Define the style settings for the shape (shape, fill, line, rotation angle) using the buttons on the toolbar.

· When the shape is set, press the Enter key or the button  of the toolbar: the shape is transferred to
the layer in use

Use of handles:
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· Left-click on one of the handles (size handles or rotating handles) and hold down the button

· Move the mouse without releasing the button

· Release the mouse button

The contour of the shapes can be transformed into a selection area:

· Adjust the position, size and rotation

· Choose from the toolbar a merging mode with the current selection (see the selection tool for more
information on merging selection areas)

· Click on the button  of the toolbar

· The shape is transformed into a selection area and the Selection tool is activated

Note: If a selection area is already active when transferring the shape to the layer, only the portion of the
shape contained in the selection is retained.

Keyboard keys:

· If you press the Alt key while moving, the shape is aligned with the grid. See alignment options.

· To fine-tune the angle of rotation press the Alt key while you rotate

· The Escape key allows you to reset the shape.

Selecting colors using the color panel or palettes:

· Fill color: click on the color

· Stroke color: Control-click the color

· Color of the gradient: click on the color while holding down the Shift key

The Shapes Toolbar

Allows you to transfer the shape to the current layer.

Transforms the contour of the shape into a selection area.

Merging mode Merging mode with the current selection when the shape is transformed into a
selection.

Angle Value of the angle in degrees of the shape with the horizontal

Stroke settings:

· Select a line color by clicking the color selection button or using the color picker tool

· Define the size of the line

· Define the line style from the list

Filling parameters:
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· Choose a brush color, gradient by clicking the color selection button or using the
color picker tool

· Choose a gradient style from the proposed list

Parameters of the form:

· Choose a form from the list

· To search for a shape, enter the name / group in the Filter field

   
  

Text tool

The Text tool allows you to draw texts in the current layer, fill them with a color or a color gradient and draw
their outline.

To add a text:

· Select the Text tool on the main toolbar, a text appears on the center of the drawing

· To edit the text, enter the text to be included on the toolbar.

· To move the text, drag and drop it.

· Using the handles change the size or change the rotation of the text.

· Define the text style settings (font, fill, line, rotation angle) using the toolbar buttons.

· When the text is set, press the Enter key or the button  of the toolbar: the text is transferred to the
layer in use

Use of Handles:

· Left-click on one of the handles (size handles or rotating handles) and hold down the button

· Move the mouse without releasing the button

· Release the mouse button

The outline of the text can be transformed into a selection area:
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· Position and adjust the size and rotation

· Choose from the toolbar a merging mode with the current selection (see the selection tool for more
information on merging modes)

· Click on the button  of the toolbar

· The text is transformed into a selection area and the Selection tool is activated

Note: If a selection area is already active when transferring text to the layer, only the portion of the text in
the selection is retained.

Keypad keys:

· If you press the Alt key while moving, the text is aligned with the grid. See alignment options.

· To fine-tune the angle of rotation press the Alt key while you rotate

· The Exhaust key is used to reset the text.

Selecting colors using the color panel or palettes:

· Fill color: click on the color

· Stroke color: Control-click the color

· Color of the gradient: click on the color while holding down the Shift key

The Text toolbar

Transfers the text to the current layer.

Allows you to transform the outline of the text into a selection area.

Merging mode Merging mode with the current selection when the text is transformed into a
selection.

Angle Value of angle in degrees of text with horizontal

Stroke settings:

· Select a line color by clicking the color selection button or using the pipette tool

· Define the size of the line

· Define the line style from the list

Filling parameters:

· Choose a brush color, gradient by clicking the color selection button or using the
pipette tool

· Choose a gradient style from the proposed list
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Font settings:

· Height: The height in pixels of the text, the width of the text is calculated
automatically according to the font parameters.

· Font: Font used to plot text

· Bold, italic, underlined, strikethrough: text style

· Spacing letters between 2 letters in percent or pixels

· Type of spacing: as a percentage of the average width of the characters or in pixels

Text Text displayed.

 

Fill tool

The Fill tool allows you to color an area bounded by a border.

To fill an area:

· Select the Fill tool from the main toolbar.

· Choose a fill color thanks to the different means of color selection (palettes, color panel, ...)

· Adjust the tool parameters (threshold, pattern)

· Click a point inside the bounded area to fill.

The Fill toolbar

Threshold This value (1-255) defines the color comparison threshold, the lower the threshold,
and the closer the colors must be to be considered equal. Conversely if the
threshold is high, two even distant colors will be considered equal. The comparison
takes into account the transparency of the colors. The threshold is used to set the
boundary between the inside of the zone and its border. A high threshold allows
partial coverage of the border. On the overlap area, the fill color is mixed with the
color of the border depending on the transparency of the border.

Pattern Allows you to select a type of fill pattern. Select a value from the drop-down list.
The No Pattern value causes a uniform filling with the color of the brush.
Loads a pattern image. Any image whose format is recognized by the application can
be used as a fill pattern.
Allows to reset the pattern if it was loaded from a file
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Use the colors of
the pattern

If a pattern is used, if this option is checked, the color of the pattern image is used,
otherwise the color of the brush is used and the pattern is used as a mask.

  

Magic wand tool

This tool allows you to select the inside of an area bounded by a border.

To select an area:

· Select the Magic Wand tool from the main toolbar.

· Adjust the tool parameters (threshold, layer selected)

· Click a point inside the delimited area to select.

· You can also select an area with the Brush tool

The Magic Wand Toolbar

Threshold This value (1-255) defines the color comparison threshold, the lower the threshold,
and the closer the colors must be to be considered equal. Conversely if the
threshold is high, two even distant colors will be considered equal. The comparison
takes into account the transparency of the colors. The threshold is used to set the
boundary between the inside of the zone and its border. A high threshold allows
partial selection of the boundary.

layer Sets the layer containing the bounded area:

· Current layer

· Over the current layer

· Under the current layer

· Topmost layer

Example of use :
A layer contains the lines of a drawing and a layer below the lines for the fill colors: select
the color layer, choose the value Layer over the current layer. With the brush tool, select
an area to be processed (Shift + mouse click) then color, repeat this process.

Gradient tool

The tool lets you fill the current layer or active selection area with a color gradient.

YoupiPaint supports 3 types of gradients:

· linear gradient: interpolates colors between a starting point and an end point
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· radial gradient: interpolates colors on a circle between a focal point and an endpoint

· Conical gradient: Interpolates colors around a central point

It is also possible to repeat or reflect the gradient by defining the propagation mode of the gradient:

· propagation on the edges
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· propagation by repetition

· propagation by reflection

The color gradation is defined by 2 or more control points on the segment linking the first to the last point.
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To add a control point, click the segment while holding down the Control key.

The control points can be moved to the segment. To move a point drag and drop with the mouse or stylus.

Each checkpoint is associated with a color of the gradient. To set the color associated with a control point,
select the control point by clicking it and select a color with the color panel or palettes.

To associate a transparent color to the control point, select it and click the button  of the toolbar.

The Gradient toolbar

Type Gradient Type:
· Linear
· Radial
· Conical

Propagation Type of gradient propagation:
· Edges
· Repetition
· Reflection
Allows you to transfer the gradient in the current layer. If a selection is active, only
the part included in the selection is transferred.

Transfer can also be performed by pressing the Enter key.
Deletes the selected point.

The point can also be deleted by pressing the Control + Delete keys.
Resets the control points and colors of the gradient.

Allows you to set a transparent color (no color) for the selected control point.

Image tool

The Image tool allows you to embed the images in the current layer.
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To add an image:

· Select the Image tool from the main toolbar.

· Click the layer where you want to embed an image.

· If no image has been defined yet, an open image dialog appears. Select the image you want to
incorporate.

· Move position, change the size or angle of rotation of the image.

· When the image is positioned correctly, press Enter or click the button  of the toolbar: the image is
integrated into the current layer.

· If you click the layer again, the process is repeated using the same image. If you want to change the
image, click the button

To copy / paste an image:

· If an image is present in the clipboard, press Paste on the Edit menu or press Control + V

· You can also copy the current selection to the clipboard

To move the current image:

· Drag and drop

To change the size or rotate the image:

· Use the handles around the image

· When changing the size the width / height ratio is preserved. If you press the Control key the size
change is free, in this case the ratio width / height is not preserved

· You can reset the transformation of the image at any time by clicking on the button 

The keys of the keyboard:

· Enter: embeds the image in the current layer

· Escape: Initially resets the process.

The Image toolbar

Shows a dialog to open image file to import

Resets the image transformation if it has been rotated or mirrored

Embed image:

· In the current layer

· In a new layer, in this case a layer is added at the top of the drawing

Vertical symmetry

Horizontal symmetry

Angle Angle of the image with the horizontal in degree

Pin the image. In this case the image is no longer movable.

Background settings

· Transparent background: If this option is checked, the image is converted to make the
background transparent by using the color of the pixel at the top left of the image or the
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color you have selected as a transparent color

· Use the pixel at the top left: If this option is checked, the transparent color is the color of
the pixel at the top left of the image, otherwise the transparent color is the color you
selected

· Transparent color: Color used as transparent color if you have not checked the previous
option.

Restrict
to
selection

If this option is checked and a selection is active, only the portion of the image included in the
selection is taken into account.

Opacity Sets the opacity of the image when it is copied to the layer.

  
  
 
   

Color picker tool

This tool allows you to select the color from a pixel on the screen.

To set the color:

· Select the color picker tool in the main toolbar 

· Click on a point on the screen

· The color under the clicked point is selected in the color panel

Comic strip tool

This tool allows you to define cartoon frames.
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From the number of rows and columns desired, a cell grid is initialized by the tool. The cells are resizable
and movable on the layer.

The displacements and alignments are facilitated by reference lines on which the displacements can be
aligned.

The cells are also selectable in order to limit the drawings made inside the cells.

The drawing of the cells can be transferred to the current layer using a brush to draw the edges.
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Select cells
Click the green control point next to the cells to select / deselect them. To extend the selection, press the
Control key simultaneously.

When a cell is selected, the control point turns red and the move and resize handles are displayed.

Add / remove alignment marks
When moving or resizing is done near an alignment mark, the position or borders of the cell are drawn to
that mark.

To add a vertical or horizontal alignment mark, click the top or left bands.

To add 2 marks spaced apart by a row or column spacing, press the Control key simultaneously by clicking.

To remove an alignment marker, click the corresponding mark in the top or left bands.

The Comic Strip Toolbar

Comic strip setup Dialog:

· Margins: pixel size of the margins of the comic strip.

· Gaps : spaces in pixels between the lines and columns of the comic strip.

· Lines / Columns: The initial line and column count of the comic strip.

Locks / unlocks cell movement

Selects all cells

Deselects all cells

Adds a cell

Deletes selected cells

Draws the cells in the current layer with the current brush

Loads the parameters and the format of the cells from a file. This function optionally adjusts the
paper size to conform to the strips.
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Saves the settings to a file

Displays or removes the borders of selected cells.

Symmetry tool

This tool makes it possible to draw symmetrically, according to any direction and according to a number of
configurable symmetries.

Example of symmetry along an axis
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Example of 5 axis symmetry

To enable symmetry:

· Click the symmetry tool  

· Position the center of symmetry on the layer

· Move the axis of symmetry

· Adjust the number of symmetries

La barre d'outil Symétrie

Blocks / unlocks the movement of control points.

Number of
symmetri
es

Determines the number of symmetry axes.

Perspective tool

This tool is used to display lines in single, double, and three-point perspectives. When this tool is enabled,
the lines drawn with the Brush tool or the Line tool are aligned in the direction of vanishing points.

To display the perspective lines:

· Select the perspective tool 

· Move vanishing points

· Add or remove control points



YoupiPaint User Manual

77 / 95

Moving perspective points

The displacement of the center of the perspective, materializing the horizon line, displaces the set of
vanishing points and control points. If you press the Control key simultaneously while moving the center,
only the vanishing points are moved with the center.

Each control point (red) has 3 associated points (yellow, green and blue) to adjust the dimension of the
perspective figure.

The Perspective Toolbar

   

Perspective Setting Dialog:
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· Left, Right, and Vertical vanishing points: Check these options to display the corresponding
points, set the distance in pixels of the vanishing points from the center of the perspective.

· Show Lines: If this option is checked, the lines of the perspective figures are displayed

· Show Cursor Lines: If checked, the lines are displayed at the mouse position

· Lock line direction: If this option is checked, the lines drawn with the Brush and Line tools
are drawn in the direction of the vanishing points

· Lock angle: defines the angle in degrees beyond which the lines are no longer blocked in
the direction of the vanishing points.

Adds a perspective figure

 Remove the last perspective figure

Blocks the movement of vanishing points and control points

Prints perspective figures in the current layer using the current brush. You can also print the
figures by pressing the Alt key and clicking on the layer.

Resets the perspective center position to the default value.

Ruler tool

This tool makes it possible to draw lines parallel to a direction. This tool also makes it possible to measure
the dimensions of the drawing.

When the rule is activated the brush strokes and lines drawn with the brush tool or the line tool are held
parallel to the ruler.

When the control points are moved, a message indicates the value of the spacing between the 2 control
points and the angle of the rule with respect to the horizontal.
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To activate the rule:

· Select Ruler tool  in the main toolbar

· Orient the ruler axis by moving the control points

The Ruler toolbar

Locks / unlocks the movement of control points.

Angle
offset

Determines the degree step of the angles of the ruler with respect to the horizontal. Adjusts the
angle of the ruler to multiples of the offset.

Unit Unit of the graduation of the ruler in inches or centimeters.

Development

YoupiPaint contains a code editor that allows you to develop new brush engines or effects, or modify those
that are provided with the application/

The development of engines and effects is based on the OpenGL Shading Language (GLSL version # 330),
which makes development extremely powerful and provides very high performance thanks to hardware
acceleration.

All parameters necessary for the execution of effects and brushes are provided as input to YoupiPaint. In the
same way, the standard procedures performing the common tasks are accessible by the developer.
Therefore, often only a few lines of code will be needed to fulfill your needs.

For example, the Gray Scale effect requires less than 10 lines of code:

@main
vec4 color = texture(f_currentLayerTexture, v_texCoords0.st);
float finalOpacity = color.a * f_opacity;
// unmultiply color components
float r = color.r / color.a;
float g = color.g / color.a;
float b = color.b / color.a;
float c = (r + g + b) / 3.0;
f_color = vec4(c, c, c, 1.0) * finalOpacity;

Once the effects and brushes are compiled successfully, they are immediately available in the application.

Thanks to this possibility of integrated and interactive development, you have no limits in the realization of
the specific needs.

New brush engine

This feature adds a new brush engine to the list.

To create a new brush engine:

· Select Brush menu> Brush engine > New brush engine

· In the dialog, enter a group name and description and click the Ok button.

· The code editor is displayed.

· Enter the brush motor code in the editor.
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Edit brush engine

This function makes it possible to modify the source code of the brush engines.

To change the engine:

· Make Brush Menu > Brush engine > Edit brush engine

· Select the engine to be modified from the list

· Click the Ok button

· Modify the source code of the brush engine.

Duplicate brush engine

This function creates a brush engine by duplicating the code of another engine.

To duplicate a brush engine:

· Make Brush Menu > Brush engine > Duplicate brush engine

· Enter the engine group and description

· Change engine source code

Assign a brush engine

This function allows you to associate a brush engine with the brush in use.

To assign the engine:

· Make Brush menu > Brush engine > Set brush engine

· Choose the engine from the list
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Reset brush engine

This function allows you to return to the standard brush engine for the brush in use.

To reset the engine:

· Make Brush menu > Brush engine > Reset brush engine

Delete brush engine

This function removes the selected engine from the list of brush engines. This operation is not reversible and
permanently deletes the brush engine and the source code associated with this engine.

To delete an engine:

· Select Brush menu > Brush engine > Delete brush engine

· Select the engine to be deleted from the list

· Confirm deletion

Add a new effect

This function adds a new effect to the list.

To create an effect:

· Select Effect Menu > Effects development > New effect

· In the dialog, enter a group name and description and click the Ok button.

· The code editor is displayed.

· Enter the effect code in the editor.

Duplicate an effect

This function creates an effect by duplicating the code of another effect.

To duplicate an effect:

· Select the effect you want to duplicate in the effects panel

· Select Effect menu > Effects development > Duplicate effect

· Enter the group and the description of the effect

· Edit the source code of the effect

Edit an effect

This function is used to modify the source code of the effects.

To change an effect:

· Select the effect you want to change in the effects panel

· Select Effect Menu > Effects development > Edit effect

· Edit the code in the editor

Delete an effect

This function removes the selected effect from the effects list. This operation is not reversible and
permanently deletes the effect and the source code associated with this effect.

To remove an effect:

· Select the effect you want to delete in the effects panel

· Select Effect Menu > Effects development > Delete an effect

· Confirm deletion
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General principles

Preamble
In the following, it is assumed that the developer is familiar with OpenGL concepts and Shading Language.

General Principles for Effects Development
In order to understand how the effects work, it is necessary to understand the layer structure of YoupiPaint

A layer consists of a set of tiles (512x512 pixels) assembled with a border covering of a width of 6 pixels.
The visible surface of each tile is therefore 500x500 pixels.

The drawings of the tiles are OpenGL textures plated on the rectangle occupied by the tile. When performing
a brush stroke or other drawing operation, YoupiPaint creates the tiles as needed and updates the textures
associated with the tiles.

- la structure des tuiles du calque -

An effect is an OpenGL fragment shader. This shader is used to display the tile texture of the current
layer. The previews of the effects are displayed in real time. When the effect is applied, the tile textures are
updated.
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General Principles for the Development of Brush Engines
As for effects brush engines are OpenGL fragment shaders.

A brush stroke consists of a set of more or less spaced buffers. These buffers are drawn dynamically or
represented by a texture in the case where the brush is associated with a texture. The fragment shader 
performs this drawing.

Inputs provided by the application to the shaders
A stamp or a tile are delimited by a quadruple point. In addition to the coordinates of the points YoupiPaint
provide inputs as uniform variables:

· The transformation matrices (projection, view, model)

· The general parameters of the application such as the coordinates and size of the paper

· The texture coordinates of the tiles for the effects, the texture coordinates of the stamps for the brushes

· The identifiers of the textures of the current layer, of the layer under the current layer

· The texture identifier used as a mask for the selection areas

· The specific parameters defined by the shader developer

· For the brushes, the dynamic parameters of the brush, calculated just before the execution of the
shader, such as radius, hardness, flow and many others.

What the shader should calculate
Like any fragment shader, effects and brush engines must calculate the color of the fragment and update
the predefined variable f_color.

All colors are pre-multiplied and must be rendered in the pre-multiplied f-color variable.

As a reminder, if r, g, b are the red, green, blue components of a color and alpha its transparency, the
corresponding pre-multiplied color is the quadruplet

(r*alpha, g*alpha, b*alpha, alpha)

Code editor

The code editor is the main tool for developing brush engines and effects. Refer to sections Effects
development et Brush engines development to see the different ways to display the editor.

The editor includes:

· A code editor at the top in which the syntax is highlighted by the coloring of keywords.

· A compilation output area at the bottom in which the compilation errors are displayed.

· A text search / replace panel
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File menu
· Save: Saves the current editing program.

· Compile: Starts the compilation of the current program and displays errors if there are any

· Exit: Exits the editor, if the program in progress has been modified a confirmation dialog is displayed to
propose recording. If the program has been modified and it has not yet been compiled, a compilation is
started to check its status before exiting.

Edit menu
· Edit controls such as copy / paste, undo / redo

· Text Search / Replace commands

Insert menu
This menu allows you to insert keywords or code fragments

· Inserting sections

· Inserting various type of parameters in the @params section

· Insertion of code fragments

Search by keywords
The editor allows you to search for keywords. To start the search, enter a text to search in the code editor
and press the Control + Space keys simultaneously. The search dialog is displayed and contains a list of
the entries corresponding to your search (text included in the keywords and / or their description). Select a
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keyword and press Enter or double click on the row to insert the keyword into the editor.

Inserting and managing code fragments

A code fragment is a code snippet used as an example to insert in the code editor.

To insert a fragment:

· Position the cursor where you want to insert the fragment

· Select Insert menu > Insert a code fragment

· The code fragment dialog is displayed



YoupiPaint User Manual

86 / 95

· Select the fragment to insert and click the Insert button.

· To add a new fragment to the list, click the button  

· To remove a fragment from the list, click the button  

· To rename a fragment, select its description in the left part and press F2 key

· To change the fragment code, enter the code in the right part.

To add a fragment directly from a selected text in the editor:

· Select the snippet you want to add as a fragment.

· Select Insert menu > Add Fragment

· Enter the description of the new fragment.

Programs structure

A program (brush engine or effect) is cut into sections :

· @param section

· @options section

· @functions section

· @main section

Except the main section the other sections are optional. You can place the sections in any order. A section
begins with the keyword of the section and stops at the beginning of another section or at the end of the
code if it is the last section. Sections contain the code to execute.

Coding
The instructions written in the @functions and @main sections are not interpreted by the editor. They are
supplied as is to the compiler integrated to the graphic card of your workstation. These instructions should
be written using GLSL (OpenGL Shading Language version # 330). For more information, please refer to the
GLSL language specification and the many sites that provide information about this language or provide
examples and tutorials.

The @params section
This section contains the program-specific settings. Each parameter is a variable that can be used in the
function code or in the main section. 

The parameters inserted in this section can be modified at program execution.
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In the case of effects, the parameters are displayed in the effect parameter dialog.

In the case of brush engines, the parameters are displayed in the brush parameters panel in the Engine
parameters category.

Types of parameters
The code editor provides an insert wizard for each parameter type.

Float type
Float types are real numbers displayed by a cursor and a number entry spinbox.

Declaration:

float <varName> = <default value> "<description>" min = <min> max =
<max> increment = <increment>;

<varName>: name of the variable as used in the shader
<default value>: default value of the variable
<description>: descriptive text as displayed in the effect or brush parameter setting
<min>: minimum value, default 0.0
<max>: maximum value, default 1.0
<increment>: cursor increment value, default 0.01

Boolean type
A boolean type is a true or false value. Boolean types are displayed with a check box.

Declaration:

bool <varName> = <default value> "<description>";

<varName>: name of the variable as used in the shader
<default value>: default value, true or false
<description>: descriptive text as displayed in the effect or brush parameter setting

Enumeration type
An enumeration type is a list of integer values. The enumeration types are displayed by a list box.

Declaration :

enum <varName> = <default value> "<description>" enum values =
   <value 1> "<value 1 description>"
   <value 2> "<value 2 description>"
   ...
   <value n> "<value n description>";

<varName>: name of the variable as used in the shader
<default value>: default value of the variable, a value in the list
<description>: descriptive text as displayed in the effect or brush parameter setting
<value> "<description>": list of enumeration values, the value usable in the shader and the description of the
value is such that it appears in the list box.

Color type
The color type is a quadruplet variable, vec4 OpenGL variable, containing the red, green, blue and alpha
components of the color. The color types are displayed with a color input field and a color selection dialog
button.

Declaration :



YoupiPaint User Manual

88 / 95

color <varName> = rgb(<red>, <green>, <blue>[, <alpha>])
"<description>";

<varName>: name of the variable as used in the shader
<description>: descriptive text as displayed in the effect or brush parameter setting
<red>, <green>, <blue>, <alpha>: RGB components, red, green an blue components from 0 to 255, black =
rgb (0, 0, 0) and white = rgb (255,255,255), transparency <alpha> from 0 to 255 is optional

Texture type
The texture types are the texture2D OpenGL variables. The texture file path is part of the variable and at run
time it is not possible to choose the image file associated with the texture.

Declaration :

texture <texture_name> "<file path>" wraps = <wrap mode s>  wrapt =
<wrap mode t> min filter = <min filter> mag filter = <mag filter>;

<texture name>: name of the variable as used in the shader
<file path>: path of the image file of the texture. The path may contain substitution variables

· $DocumentsPath$: path of user documents (eg under Windows the Documents directory)

· $ImagesPath$: image directory path

· $InstallationPath$: path to the installation directory
<wrap mode s>, <wrap mode t>: parameter of the OpenGL S and T texture wrap. The wizard provides a list
of possible values.
<min filter>: parameter of the OpenGL minification filter. The wizard provides a list of possible values.
<mag filter>: parameter of the OpenGL magnification filter. The wizard provides a list of possible values.

When compiling, YoupiPaint checks the existence of the image file and gives a warning if the file does not
exist.

The @options section
This section contains run-time options, such as setting texture options for layers.

The @functions section
This section contains the code of the callable functions in the @main section.

The @main section
This section contains the main code of the program.

Compilation of programs

Compilation is a mandatory prerequisite before an effect or brush engine is available.

The compilation consists of:

· Check the code written in the @params and @options sections

· Generate the final program in the GLSL language by adding to the program code the internal code of the
application

· Have the program generated compiled by the graphics card installed on your workstation.

· Display any errors that occurred during each of these steps.

If errors are detected, they are displayed in the editor's compilation console.
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List of variables

A multitude of variables are provided to the shaders and can be used by them:

The effects variables

// datas from the vertex shader
in vec4 v_color; // color of the vertex
in vec2 v_texCoords0; // texture 0 coordinates: coordinates in the current
layer
in vec2 v_texCoords1; // texture 1 coordinates: not used
in vec2 v_texCoords2; // texture 2 coordinates: not used

// textures 
uniform sampler2D f_currentLayerTexture; // id of the current layer texture
uniform sampler2D f_underLayerTexture; // id of the layer under the current
layer texture
uniform sampler2D f_paperTexture; // id of the paper texture
uniform sampler2D f_selectionLayerTexture; // id of the selection mask texture

// General parameters
uniform vec2 f_texturePos; // texture top left position in canvas coordinates
uniform float f_textureSize; // texture size
uniform vec2 f_paintedRectPos; // painted rectangle top left position in
canvas coordinates
uniform float f_paintedRectWidth; // painted rectangle width
uniform float f_paintedRectHeight; // painted rectangle height
uniform bool f_clipToPaintedRect = true; // true -> clip to paintedRect
uniform bool f_clipToSelection = false; // true -> clip to selection
uniform float f_opacity = 1; // current layer opacity
uniform float f_globalTime = 0; // time elapsed in seconds since application
start

out vec4 f_color; // shader output color

Brush engines variables

// datas from the vertex shader
in vec4 v_color; // brush color
in vec2 v_texCoords0; // texture coordinates 0: texture coordinates of the
stamp
in vec2 v_texCoords1; // texture coordinates 1: current layer texture
coordinates
in vec2 v_texCoords2; // texture coordinates 2: not used

// datas computed for each stamp buffer
uniform float f_radius = 10; // stamp radius
uniform float f_hardness = 1.0; // brush hardness
uniform float f_density = 1.0; // pixels density
uniform float f_flow = 1.0; // brush color flow
uniform float f_opacity = 1.0; // brush stroke opacity
uniform int f_compositionMode = 0; // composition mode
uniform bool f_inheritAlphaUnder = false; // indicates if the brush should
blend using the alpha of the layer under the current layer
uniform int f_alphaEquation = 0; // mask equation
uniform bool f_inheritAlphaCurrent = false; // indicates if the brush should
blend using the alpha of the current layer
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uniform bool f_hasTexture = false; // indicates if the brush has a texture
uniform bool f_preserveTextureColor = false; // indicates if the color of the
texture is used instead of the brush color
uniform float f_colorAbsorbtionRate = 0.0; // brush color absorption rate
uniform float f_colorFlowingRate = 1.0; // brush color flowing rate
uniform int f_antialiasing = 0; // antialiasing 0[antialiasing] 1[no
antialiasing]
uniform bool f_clipToSelection = true; // indicates if the stamp should be
clipped to selection mask
uniform int f_shape = 0; // brush shape 0[ellipse], 1[rectangle]
uniform float f_factor = 1.0; // factor used in composition formula [0, 1]
uniform vec4 f_borderColor = vec4(1, 1, 1, 1); // color of the border of the
stamp
uniform bool f_useBorderColor = false; // indicates if border color should be
used
uniform int f_stampCount = 1; // stamp count since the beginning of a stroke
uniform float f_random = 1.0; // random number given for each stamp buffer
uniform vec2 f_texturePos; // texture top left position in canvas coordinates
uniform float f_textureSize; // texture size
uniform vec2 f_paintedRectPos; // painted rectangle top left position in
canvas coordinates
uniform float f_paintedRectWidth; // painted rectangle width
uniform float f_paintedRectHeight; // painted rectangle height
uniform sampler2D f_currentLayerTexture; // texture id of the current layer
uniform sampler2D f_underLayerTexture; // texture id of the layer under the
current layer
uniform sampler2D f_brushTexture; // texture id of the brush texture (if a
texture is assigned to the brush)
uniform sampler2D f_colorTexture; // texture id of the color buffer
uniform sampler2D f_selectionLayerTexture; // texture id of the selection mask
out vec4 f_color;

Standard procedures

Brush engine standard procedures

Color computation
vec3 getStandardColor(vec2 uv, float alpha)

This procedure calculates the color of the buffer, taking into account the brush parameters (color, hardness,
opacity and all other parameters). the calculated color is not pre-multiplied, the red, green, blue components
are given in the return variable vec3.

Note on the absorption of the color present on the layer by the brush. The absorption mechanism works by
taking a regular sample of the color of the layer at the position of the brush marks and using the absorption
rate of the brush. This step is not done in the shader of the brush engine but in a shader dedicated to this
which is executed upstream. However, this sample is available in the shader of the brush engine with the
texture variable f_colorTexture.

Blending computation
vec4 getStandardComposition(vec3 sourceColor, float alpha)
 
This procedure calculates the brush composition according to the SVG standard specifications (available at
https://www.w3.org/TR/SVGCompositing/). The source color before composition must be provided in the
non-pre-multiplied sourceColor variable and the transparency of the fragment in the alpha variable.
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Transparency computation
float getStandardAlpha(vec2 uv)

this procedure calculates the standard transparency of the fragment taking into account brush parameters
such as shape, brush texture, or brush hardness. The uv variable must contain the buffer's texture
coordinates, (provided by v_texCoords0).

Selection mask
float getStandardClipping(float alpha)

This procedure calculates the restriction to the selection buffer from the input transparency: if the fragment
is contained in the selection area, the transparency is returned otherwise the returned transparency is zero.

Effects standard procedures
bool inRect(float x, float y)

This procedure tests the inclusion of coordinates in the painted rectangle. If coordinates are included returns
true, otherwise false. The x and y coordinates must be provided in the canvas coordinate system.

To calculate these coordinates from texture coordinates, apply the following formulas:

float x = (v_texCoords0.x * f_textureSize + f_texturePos.x -
f_paintedRectPos.x) / f_paintedRectWidth;
float y = (v_texCoords0.y * f_textureSize + f_texturePos.y -
f_paintedRectPos.y) / f_paintedRectHeight;

Restore the default layout

This function returns the original layout of the panels and toolbars.

To restore the default layout:

· Select Window Menu > Restore default layout

Reset canvas position

This function allows you to reset the rotation, zoom and move the drawing.

To reset the position of the canvas:

· Select Menu Window > Reset canvas position

Adjust to width

This function adjusts the drawing view to the width of the screen.

To adjust to the width:

· Select Menu Window> Adjust to width

Adjust to height

This function adjusts the drawing's view to the height of the screen.

To adjust to height:

· Select Menu Window > Adjust to height
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View all canvas

This function displays the entire drawing.

To see the whole document:

· Select Menu Window > View all canvas

Flip horizontally

This function performs a horizontal symmetry of the drawing view. The drawing itself is not transformed, only
the view is modified.

To reverse horizontally:

· Select Window Menu > Flip horizontally

Flip verticaly

This function performs a vertical symmetry of the drawing view. The drawing itself is not transformed, only
the view is modified.

To reverse vertically:

· Select Window menu> Flip verticaly

Window transparency (on/off)

This function makes it possible to modify the transparency of the main window of the application to reveal
what is underneath.

To change transparency:

· Select Window Menu> Window Transparency (on / off)

Increase the transparency of the window

This function increases the opacity of the main window.

To increase transparency:

· Select Window Menu> Increasing Window Transparency

Decrease the transparency of the window

This function decreases the opacity of the main window.

To reduce transparency:

· Select Window Menu> Decreasing Window Transparency

Full screen

This function maximizes the display of the drawing by hiding the panels.

To enter or exit the full screen display:

· Select Window Menu> Full Screen (Function Key F12)

Restart application

This function restarts the application. A reboot may be required to accommodate changes to some
application options.

To restart the application:

· Select Menu Window > Restart the application
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Panels

This function displays the list of application panels.

The displayed signs are checked. To show / hide a panel, click the item in the list.

Toolbars

This function displays the list of toolbars in the application.

The displayed toolbars are checked. To show / hide a toolbar, click the item in the list.

Note: The toolbars associated with the tools are automatically displayed when a tool is selected.

Screenshot

This function is use to take a screenshot of the main window. It is useful to report an issue to the support.

To take a screenshot:

· Select Window Menu > Take a screenshot

· Enter the fields in the the screen-shot dialog

· Click the Ok button

The image is saved and copied in the clipboard.

 

File name Name of the file where the screenshot is save. Click on the button to show a file dialog.

Width/Hei
ght

Width and height of the screenshot. Click on the refresh button to reset the width and height to
the actual window size

Lock
width/heig
ht

If this option is checked the width and height fields are proportionals. 

Keep ratio If this option is checked, the screenshot is adjusted to the image rectangle
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Backgrou
nd

Choose a transparent background or a colored background.
Note : transparent background may not work with some image formats, choose an appropriate
image file extension to get a working transparent background.

Backgrou
nd color

For colored background choose the color.

Copy
image to
clipboard

if this option is checked the screenshot is sent in the clipboard.

Help functions

Help index
Shows the local help index.

On line help
Returns to the online help on the YoupiPaint website.

Check updates
Queries the YupiPaint website to determine if updates are available or if the version installed on your
computer is the latest update.

Contact us
Go to the YoupiPaint website

About YoupiPaint
Displays a dialog indicating the version of YoupiPaint and the license granted to the user.

Register product

This feature allows you to register the product when it was purchased. A registered version gives unlimited
access to all YoupiPaint features.

When you purchase the product an email containing a product registration key is sent to you. If you did not
receive this email when buying contact the support.

To register the product.

· Make Help menu > Register product

· Enter the registration key

· Click the Register button.

If the registration is successful, a thank-you message is displayed.

System logs

This function is used to show the system logs. The system logs are updated at each starup and may
contains useful errors to show to the support. The function allows to send the logs to the support for
debugging purpose.

To show the logs:

· Make Help menu > Show system logs

· Add a optional comment 

· Enter your eMail address so that the support can contact you

· Click Send logs to support
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